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Browsing your Budget Structure 
Access to performance data can be done either through the File->Open Performance menu item or through the File-
>Open Operating Browser (if user has operating access).  If you have access to the operating budget module of ABS, the
performance data can be found on the core services tab of the department, rdu, and component edit windows.

When using the Performance browser, click on the name of the item for which you want to add or modify performance 
information.  The browser will default to only showing those structure items that already contain performance data, if you 
need to add new performance data click the Show All Filter in the upper right to access other RDUs/components. 
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The department, RDU, and component windows hae similar layouts.  The performance data can be found on the Core 
Services tab. 

Department authorized operating users can restrict edit capability to select Dept/RDU/Components through the Tools-
>User/Group Security – Operating menu interface.

Published vs Draft Edit Modes 
Information on the Performance windows can be edited in two modes – Published and Draft.   The edit mode is displayed 
in the upper right corner of the window.  Published data will be uploaded to OMB’s website and included in the budget 
book.   

Published Edit Mode 

Published mode is best for adding, editing, and deleting information which does not require any sort of approval process.  
Typically data updates are done in published mode because the targets have already been published and reviewed. 

Draft mode can be used when edits require review prior to making public.  This would be used when a new performance 
framework is being proposed or a new target. 

Published targets cannot have their details edited in draft mode.  To create draft changes to an existing target, duplicate 
the target in draft mode, make edits in the new draft version, and mark the published version for deletion.  This way once 
all of the changes are approved, the new draft version will be swapped in place of the published version. 
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If you want to propose the removal of a piece of information, click the Delete link while in draft mode and it will appear as 
strike-through text.  Once marked for deletion, it can be restored but it cannot be further edited.  If a result or core service 
is marked for deletion, all of the related targets will also be marked for removal. 

If something new is added in Draft Mode, it will appear purple.   

To approve changes and make them visible on (or delete from) the public web site and budget book,  click on the  
Approve Change link next to each item or click on the Approve All Draft Changes link in the upper right under the edit 
mode.   

Things to be aware of in Draft Mode 

�x Tables, graphs, and the Analysis cannot be edited in draft mode for published targets – a duplicate draft version of the
entire target needs to be created.  The Duplicate option ca
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�x There is currently no user-level security associated with who can approve changes in draft mode.  At this time, it is up
to departments to determine how the Draft Mode feature will be used and who should be approving proposed
changes.

�x If you want to create a MS-Word document comparing the published and draft changes you can run two versions of
the same RTF report, one in Published and one in Draft Mode (ABS report #1808 vs #1809), and then use MS-Word’s
“Compare and Merge Document” feature under the Tools menu to create a document showing the changes.  This is
helpful for having agency people who are not Performance site users review changes.

End Results & Core Services 
Each RDU/Component can have one or more Results and Core Services.  Each Core Service must be linked to one 
Result.  While Results themselves are not printed in the budget book, the targets associated with Results are printed after 
the mission statement for RDUs and components.  For the department level, select key performance indicator targets are 
printed by priority program as the department-level core services.  The department level does not have the same core 
service options that RDUs and components have 
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Targets 
To view specific targets within a Result or Core Service, click on the Edit Targets link to the right of the title.  The quantity 
of targets will be shown in parantheses. 

 

The target listing window: 

 

Click the Add new target link to create a new Target for the result or core service.  New targets will appear at the end of 
the target listing and be displayed in the order they are entered, the order of the targets within a result or core service can 
be changed by clicking on the Sort Targets link. 

To edit the details of a target, click the Edit link to the right of the target title. 

 

Click the Delete link next to a target to delete them.   

Targets can be duplicated as a starting point for a similar target
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Each row of the table must represent a year or quarter’s worth of data.  The time period of the year can be clarified by 
choosing Calendar, Fiscal Year, or Federal Fiscal Year from the choices at the top of the table.  If you choose the “Fiscal 
Year” option, the years will be displayed with an “FY” in front of all years (eg FY2004 instead of simply 2004). If you 
choose the “Federal Fiscal Year” option, the years will be displayed with an “FFY” in front of all years.  The YTD column 
default is to represent a year-to-date total with columns 1-4 assumed to be quarters but this is not a required layout.  The 
last two columns can be used to show a Target value and Variance from the target.  The “Visibility” checkbox for each row 
determines if the information will be displayed to the public and transferred to the website and included in the budget 
book.  It may be useful to hide data until it is approved by unchecking the visible option for certain rows.  The “Compute 
YTD” setting controls the display of the “YTD Total” Column.  If Compute YTD is set to “Values,” the YTD column will 
automatically total the numbers in the first four columns.  If Compute As is set to “Text,” whatever the user types in the 
YTD column will be displayed without any calculations being made.  The rows will be sorted in descending order so the 
most recent year appears on top.  Permanently remove rows using the Delete link on the right side of the row. 

The Methodology field is used to describe the methodology used for the collection of the data in the table and should be 
filled in for all targets. 

When the table is displayed on the web or the budget book, a percentage change between rows can be optionally added 
below each value.  This calculation will not be made if one of the values to be compared is not a number or if you uncheck 
the “Show % change” option at the top of the table. 
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Show value in graph  – Determines whether each plot point displays the cell’s value within the graph.  For example, the 
exact value would show in the graph at the top of a bar in a bar chart or at a data point in a line graph. 

Translucent  – Changes the bar or line to translucent.  This can be helpful when combining line and bar graphs or 
displaying values within the graph to improve appearance. 

Override vertical axis scale  – This minimum and maximum value can be used to override the vertical axis scale.  The 
graph will usually pick a logical range for the given values given but if you want to override these values with a larger or 
smaller range, enter a non-zero amount in at least one of these two fields. 

Technical Tips and Known Issues with Graphs 
�x If you want to graph data by quarters, select the year-quarter values in the year dropdown (2006-Qtr1, 2006-Qtr2, etc) 

in the first column of the table and override the default quarter table column header titles to reflect your data. 

�x Columns of data from left to right are presented in stacked bar graphs from bottom to top. 

�x Stacked bar graphs and regular bar graphs cannot be combined because stacked bars draw over the top of regular bar 
graphs.  Stacked bar graphs are best combined with a line graph if needed. 

�x The only symbols that are allowed in graphed column values are $, %, decimals, and commas.  Any other symbols or 
letters will create an error or be treated as zero as the graph is generated because they are not interpreted as 
numerical information. 

�x The presence of %, $, or decimals in the data being graphed will cause the vertical axis scale to be formatted similarly.  
If more than one format is present, the format of the last graphed column in the table from left to right will be used. 

�x You don’t have to display a table to have a graph.  You can check the Hide box for all of the columns in a table and still 
have the graph display. 
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Graphing Examples 
The following pages show example graphs and the table information used to generate them. 

Example 1 - Single Bar Graph 

 
 

Example 2 - Multiple Bar Graph 

 
 

Example 3 - Multiple Line Graph with a 
Gap/Target 

. 

Example 4 - Multiple  Line Graph using 
Quarterly data 

 
 

Example 5 - Stacked Bar Graph 

 
 

Example 6 - Mixing Graph Types 
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Example 1 – Single Bar Graph 
The following table settings produce a bar graph which plots a single column’s worth of data.  The first column’s “Graph 
as” value has been changed to Bar, the color Blue chosen, and the Show value has been checked so the numbers are 
shown above each bar.  The Y axis maximum value has been increased to 150000 using the override vertical axis scale. 
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Example 2 – Multiple Bar Graph 
The following table settings produce a multiple bar graph which plots two sets of data for each year.  The first and second 
columns’ “Graph as” value have been changed to Bar, the colors Red and Blue are chosen, and the Show value has been 
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Example 4 – Multiple Line Graph using Quarterly data 
The following table settings produce a multiple line graph for a single year.  The first and second columns’ “Graph as” 
value have been changed to Line, the colors Green and Blue are chosen, and the Show value has been set to Top for the 
first column and Bottom for the second.  The y-axis had defaulted with a range of 66% to 82% so the vertical axis 
minimum and maximum have been overridden with values of 0 and 100.  The vertical axis labels automatically format with 
a percentage sign due to the presence of percentage symbols in the data. 
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Example 5 – Stacked Bar Graph 
The following table settings produce a stacked bar graph for multiple years.  The first, second, and third columns’ “Graph 
as” value have been changed to Stack.   
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Example 6 – Mixing Graph Types 
The following table settings produce a mix between a bar and line graph for multiple years.  The first column of the table 
contains the yearly harvest data and has the “Graph as” option set to Bar.  The Target column of the table is used to show 
a cross-year goal of 70% by selecting Line as the “Graph as” value.  The Translucent option has been selected to make 
the values more visible within the blue bars. 
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Adding Department Key Performance Indicators  
Key Performance Indicators are specially selected targets, selected by the department from the department’s 
performance framework at any level (Dept/RDU/Component), that best reflect results achieved with current capacity.   

  

Key Performance Indicator targets are selected at the top of the Edit Target window in ABS.  The value will default to 
None and has a dropdown of the available Department Priority Programs. 

 

Key Performance Indicators display only at the Department Level on the website and in budget narrative. They may be 
selected from any budget structure level in the Department’s performance framework.  Remember that only the graph 
associated with a target will be printed in the ABS budget book but all of the details entered for a target are available on 
the public performance website.   

Department Priority 
Program 
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Adding Priority Program Descriptions 
Contact your OMB analyst to update the description posted underneath the priority programs when uploaded to the 
website.  The descriptions are found under Tools->Maintenance – Operating->Programs – Department. 
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